Skip to content
PYGWALKER
安装

安装

系统要求:

  • Python 3.0 或更高版本
  • 支持 macOS、Windows 和 Linux。

使用 Pip 安装

pip install pygwalker

pygwalker/graphic-walker 经常更新新功能,您可以使用以下命令安装最新版本:pip install pygwalker --upgrade

从 conda-forge 安装

conda install -c conda-forge pygwalker

或者

mamba install -c conda-forge pygwalker

查看 conda-forge feedstock (opens in a new tab) 获取更多帮助。

本地开发

git clone git@github.com:Kanaries/pygwalker.git
 
cd pygwalker
 

构建 web 应用:

# pygwalker/app
cd app
 
yarn install
 
yarn build

安装依赖:

# pygwalker
 
pip install -e .

运行示例

您可以在 pygwalker 项目的根目录中创建一个 .ipynb 文件,然后直接导入 pygwalker 进行测试。

# pygwalker
 
jupyter-lab .

还有其他问题吗?欢迎在我们的 github (opens in a new tab) 上提出问题或在 discord 频道 (opens in a new tab) 进行讨论。